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The FrontPage 2002 Screen The Views Panel 

 

The Fundamentals 

The Standard Toolbar 

 

• To Create a New Page or Web Site: 
Click the New button list arrow on the Standard 

toolbar and select Page or Web, or select File → 

New → Page or Web from the menu. Then 
choose the type of Page or Web you want to use 
from the task pane. 

• To Open a Page or Web Site: Click the 

 Open button list arrow on the Standard 

toolbar and select Page or Web, or select File → 
Open or Open Web from the menu. 

• To Preview a Web Page in a Browser: 

Click the  Preview in Browser button on the 

Standard toolbar, or select File → Preview in 
Browser from the menu. 

• To Insert an Image: Click the  Insert 

Picture From File button on the Standard 

toolbar, or select Insert → Picture → From 
File from the menu. 

• To Copy Formatting with the Format 
Painter: Select the text with the formatting you 

want to copy. Click the  Format Painter 
button and drag the Format Painter across the 
text to which you want to apply the formatting. 

• To Get Help: Press <F1>, or click the Help 
button to open FrontPage Help. 

• To Insert a Table: Click the  Insert Table 

button on the Standard toolbar, or select Table 

→ Insert → Table from the menu.  

• To Insert a Hyperlink: Select the text to be 

linked and click the  Insert Hyperlink button 
on the Standard toolbar. 

• To Cut or Copy: Select the text and click the 

 Cut button or  Copy button on the 
Standard toolbar, or press <Ctrl> + <X> (cut) or 
<Ctrl> + <C> (copy). 

• To Paste: Click the  Paste button on the 

Standard toolbar, or press <Ctrl> + <V>. 

• To Undo: Click the  Undo button on the 

Standard toolbar, or press <Ctrl> + <Z>. 

• To Save a Web Page: Click the  Save 

button on the Standard toolbar, or select File → 
Save from the menu, or press <Ctrl> + <S>. 

• To View the Folder List or Navigation 

Pane: Click the  Toggle Pane button on the 

Standard toolbar. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Keyboard Shortcuts 
  Open a Web site <Ctrl> + <O> 
  or Web page 

  Save a Web page <Ctrl> + <S> 

  Print a Web Page <Ctrl> + <P> 

  Close a Web page <Ctrl> + <F4> 

  Undo <Ctrl> + <Z> 

  Redo or Repeat <Ctrl> + <Y> 

  Help <F1> 

  Refresh  <F5> 

  Switch Between <Alt> + <Tab> 
  Applications 

  Preview in Browser <Ctrl>+<Shift>+<B>  

  Create a Hyperlink <Ctrl> + <K> 

  Cut <Ctrl> + <X> 

  Copy <Ctrl> + <C> 

  Paste <Ctrl> + <V> 

  Beginning of a Line <Home> 

  End of a Line <End> 

  Beginning of <Ctrl> + <Home> 
  Web Page 

  End of Web Page <Ctrl> + <End> 

  Bold <Ctrl> + <B> 

  Italics <Ctrl> + <I> 

  Underline <Ctrl> + <U> 

  Align Left <Ctrl> + <L> 

  Center <Ctrl> + <E> 

  Align Right  <Ctrl> + <R> 

Shows current Web page in different 

views: Normal, HTML, and Preview. 

Allows you to analyze and view the 

status of elements in the Web site 

Shows the structure and organization 

of the Web site. 

Shows the hyperlinks to and from 

each page in the Web site 

Shows all the files and folders in the 

Web site 

Keeps track of tasks that need to be 

completed in the Web site 
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Formatting Tables 

  The Formatting Toolbar 

 

 

The Tables Toolbar 

 

• To Format Text: Change the style of text by clicking the  Bold button, 

 Italic button, or  Underline button on the Formatting toolbar. 

Change the font type by selecting a font from the  Font list. 

Change the font size by selecting the pt. size from the  Font Size list or 

by using the  Increase  Decrease Font Size buttons. 

• To Change Paragraph Alignment: Select the text and click the 

appropriate alignment button (  Left,  Center,  Right or Justify). 

• To Indent a Paragraph: Click the  Increase Indent button. 

• To Decrease an Indent: Click the  Decrease Indent button. 

• To Create a Bulleted or Numbered List: Select the text you want 

bulleted or numbered and click the  Bullets button or the  Numbering 
button. 

• To Change Table Borders: Click the  Table Border button to 
apply the border format shown on the button, or click the Table Border list 
arrow to select a different type of border. 

• To Change Paragraph Line Spacing: Select Format → 
Paragraph from the menu, click the Line Spacing list arrow, and select the 

spacing option. 

• To Insert a Line Break: Place the insertion point where you want to 
insert the page break and press <Shift> + <Enter>. 

• To Apply a Theme to a Web site: Select Format → Themes from 
the menu, select a theme, and click OK. 

 Pictures 

  The Pictures Toolbar 

 

• To Insert an Image: Click the  Insert Picture From File button, or 

select Insert → Picture → From File from the menu. 

• To Add a Hyperlink to an Image: Select the picture and click the  
Insert Hyperlink button on the Standard toolbar, or select Insert → 
Hyperlink from the menu. 

• To Create a Thumbnail Image: Select the image, and click the  
AutoThumbnail button on the Pictures toolbar. 

• To Create an Image Map: Click the  Rectangular,  Circular, or 

 Polygonal Hotspot button, draw the hotspot shape over the image, then 
verify the hyperlink’s location. 

• To Highlight Hotspots: Click the  Highlight Hotspots button. 

• To Crop an Image: Click the  Crop button on the Pictures toolbar, 
and drag the cursor over the part of the image you want to keep. 

• To Resize an Image: Click and drag its resizing handle in the direction 
you want to resize the picture. 

• To Create a Table: Click the  Insert Table button on the Standard 

toolbar and select the number of columns and rows from the grid. 

• The <Tab> key goes to the next cell; the <Shift> + <Tab> shortcut goes to 
the previous cell. 

• To Delete a Column or Row: Select the column or row, click the right 
mouse button, and select Delete Cells from the shortcut menu, or select 

Table → Delete Cells from the menu. 

• To Insert a Column or Row: Click the right mouse button and select 

Insert Columns or Insert Rows from the shortcut menu, or select Table → 
Insert → Rows or Columns from the menu. 

• To Change Alignment of Text in a Cell: Place the insertion point in 

the cell, and click the Align Top, Center Vertically, or Align Bottom 
button. 

• To Fit to Column Contents: Place your insertion point in the column 

you want to fit and click the AutoFit button.  

• To Adjust Cell Padding or Cell Spacing: Right-click anywhere in 

the table and select Table Properties, or select Table → Properties → 

Table from the menu. Then adjust the cell padding or spacing in pixels. 

• To Change Table Border Width: Right-click the table and select 

Table Properties, or select Table → Properties → Table. Then change 
the width of the table’s borders in pixels. Enter zero pixels for an invisible 
border. 

• Display a Table in Pixels or Percent: Right-click the table and 

select Table Properties, or select Table → Properties → Table. A table 
displayed in pixels will appear the same size, regardless of the size of the 
monitor on which it is viewed. A table displayed in percent will adjust to a 
percent of the monitor on which it is viewed.  

  Page Views 

           

 

  Hyperlinks 

• To Insert a Hyperlink: Select the text to be linked, and click the  
Insert Hyperlink button on the Standard toolbar, or select Insert → 
Hyperlink from the menu, or press <Ctrl> + <K>. 

• To Create a Hyperlink to Another Page in the Web site: 

Select the page in the Create Hyperlink dialog box, and click OK. 

• To Create a Hyperlink to a Page on the Internet: Enter the URL 
of the Web page in the Create Hyperlink dialog box, or click the Browse the 
Web button to browse the Web for a page. 
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Introduction

Whether you’re at work or home, a Web site is one of the easiest ways to distribute 

information. For example, in a large corporation, each department could have its 

own Web site on an intranet to let the rest of the company know what’s going on. 

With Microsoft® FrontPage® 2002, anyone can build professional, attractive Web 

pages and Web sites.

The best way to get acquainted with FrontPage 2002 is through hands-on practice. 

In the following two lessons, you’ll build a Web site that provides information about a 

fictional sporting goods store called Championzone. There is a prepared folder of files 

for you to practice with while you create this Web site. These practice files were 

installed in the FPTutor2002 folder on your hard disk along with this tutorial.

The following image shows the Web site you will create using this Tutorial.

Before You Begin

Overview

• The tasks in this tutorial require that your computer meet the minimum 

system requirements for FrontPage 2002. For more information, please visit 

the FrontPage Web site, at http://www.microsoft.com/frontpage

• If you haven’t already installed FrontPage, you’ll need to do so before you 

begin this tutorial.

• The pages you create will more closely match the screen examples in this 

tutorial if you use a standard monitor set to a minimum screen resolution of 

800x600. If you are using a different resolution, the pages you create may 

look slightly different from the examples pictured in the tutorial.

http://www.microsoft.com/frontpage
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If you have Web server software installed

The Web site you will create while taking the FrontPage Tutorial will be saved to a 

folder on your local hard disk. If you are running Web server software such as 

Microsoft Internet Information Services (IIS), you can either accept the default 

destination for the tutorial Web site, or choose to save it directly on your Web 

server.

FrontPage and Microsoft Internet Explorer

To get the most out of FrontPage, installing Microsoft Internet Explorer is 

recommended. When Internet Explorer is installed, FrontPage provides enhanced 

page and themes preview. Other Web browsers currently do not support these 

additional features.

   Tip   You can use more than one Web browser. If you already have another 

Web browser installed on your computer, you can still safely install Microsoft 

Internet Explorer. When designing Web pages, you will find it is actually very 

beneficial to test your work in more than one type of Web browser before you 

publish your Web site.

If you are using Windows NT
® 

Workstation 4.0 or Windows NT 

Server 4.0

The lessons in this tutorial are designed to be completed using FrontPage 2002 on a 

computer running Microsoft Windows 98, Microsoft Windows 2000, or Microsoft 

Windows Millennium Edition. If you are using Windows NT, you may notice minor 

differences in the user interface and the way folders are referenced.

• For example, the My Documents folder in Windows 2000 is called Personal in 

Windows NT. These differences do not affect the functionality of FrontPage, 

nor do they prevent you from successfully completing this tutorial.

What You Will Learn

This tutorial is divided into two lessons:

Lesson 1: Creating Web Pages

This lesson teaches you how to work with text and hyperlinks; add pictures, 

animations, clip art, and files; format lists; position objects; design a feedback form; 

make a photo gallery; design a Web site structure; and create a Web site.

Lesson 2: Enhancing and Publishing a Web Site

In this lesson, you will learn how to set up navigation, add shared borders and link 

bars to pages, insert page banners, apply and customize a graphical theme, check 

spelling and replace text across the Web site, sort and organize files and folders, 

view Web site reports, and preview and publish the finished Web site.

Learning More About FrontPage

Using the Answer Wizard

FrontPage includes a comprehensive Help system that contains conceptual overviews 

of key features, step-by-step procedures, and complete, context-sensitive Help. It 
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contains the Answer Wizard, which you can use to ask questions about features in 

your own words.

To quickly access the Answer Wizard:

1. Locate the Ask a Question box  on the menu bar.

2. Type a question in your own words.

For example, type “How do I check the spelling on my page?”

3. Press ENTER.

Note   Not all languages support the Ask a Question box.

Using the Glossary

While taking the FrontPage Tutorial, you may come across terms that are new to 

you. These terms might appear in the FrontPage user interface, or they may be used 

in the Internet community. To look up the definitions of words you are unfamiliar 

with, use the glossary in the Online Help system in FrontPage 2002.

To locate the glossary, do the following:

1. In the Ask a Question box, type the word FrontPage.

Important   If you don’t type a word or phrase that is specific to FrontPage, 

the online Help system for Microsoft Office XP might be displayed instead of 

the Help system for FrontPage.

2. Press ENTER.

3. In the list of displayed items matching the search term, click the first item.

4. Click the Show icon  on the Help toolbar.

5. The hidden pane showing the Contents, Answer Wizard, and Index tabs is 

revealed.

6. Click the Contents tab.

If there is a plus sign (+) next to the Microsoft FrontPage Help book, that 

means the contents of that list are “collapsed,” or hidden. If you see a plus 

sign, you can expand the list.

7. Click the Plus sign  to the left of the book icon.
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8. At the bottom of the list of topics that appears, click the plus sign next to the 

list item titled Glossary.

In the expanded list under Glossary is a single topic, also titled Glossary.

9. Click the topic titled Glossary .

In the right pane, an alphabetical list of terms appears.

10. Scroll through the list to find the term you want to know.

11. Press the Close button  when you’re done.
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Lesson 1  Creating Web Pages

In this lesson, you’ll create a Web site that provides information about a fictional 

sporting goods store called Championzone. The site will contain merchandise 

information, an online photo gallery, and a list of links to other sites.

There is a prepared folder of various files for you to practice with while you create 

this Web site. The folder is located at <drive>:\FPTutor2002, where <drive> 

represents the hard disk where you installed the tutorial. When you have completed 

the lessons, you should have a good understanding of FrontPage and its features.

Overview

You will learn how to:

• Open FrontPage.

• Create Web pages.

• Work with text and hyperlinks.

• Insert pictures and files.

• Format lists.

• Position objects.

• Add a feedback form.

• Design a photo gallery.

• Create a Web site structure.

• Save your work.

Opening FrontPage

To run Microsoft FrontPage, do the following:

• On the Windows taskbar, click the Start button , point to Programs, 

and then click Microsoft FrontPage.

If this is the first time you’ve used FrontPage, the program opens and 

displays a blank page ready for editing.

Notes

o If FrontPage has been used to edit another Web site, it will open the 

last Web site automatically.

o To close a Web site: on the File menu, click Close Web.
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Workspace Overview

FrontPage 2002 has an integrated interface that helps you create and edit Web 

pages as well as manage entire Web sites within one application. All toolbars and 

menu behaviors are consistent with Microsoft Office XP programs, so toolbars and 

menus can be fully customized. You can also use convenient keyboard shortcuts to 

accelerate common tasks such as opening Web sites and pages, printing, and many 

other commands.

The graphic and table below highlight some of the commonly used elements of the 

FrontPage 2002 interface.

Item Description

Page Tab An easy way to select the page you want 

when you have several pages open.

Title Bar Displays the name of the current page, 

and its location in your Web site.

Menu Bar Contains menus like File, Edit, View, 

and Insert, and is the starting point for 

many of the tasks you will undertake in 

FrontPage.

Ask a Question Box To find more information about a 

procedure in FrontPage, type a question 

in the Ask a Question box, which 

accesses the online Help system.

Close Page This button closes the page that is 

currently in view.

Scroll Bars These let you move the page so a 

different portion is displayed.

Status Bar Represents the state of a current task. 
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For instance, the Status Bar may display 

the text “Retrieving Index.htm” when 

opening the home page, or show the 

destination of a hyperlink when you 

move your mouse cursor over a link in 

the Normal pane.

Page View Panes These represent the different panes of 

the workspace. For example, the Normal 

pane is where you will do most of your 

work in this tutorial. Other panes are the 

HTML pane and the Preview pane.

Progress Indicator Shows the status of a current action.

Estimated Download Time Gives you an idea of how long it will take 

a user to view your page in a Web 

browser.

Task Pane A pane within Office XP programs that 

provide commonly used commands. Its 

location and small size allow you to use 

these commands while still working on 

your files.

Standard and Formatting toolbars Displayed by default. They provide easy 

access to the commands you will use 

most often when working in FrontPage.

Views bar What you see in the main program 

window depends on the currently 

selected view. The icons on the Views 

bar provide different ways of looking at 

the information on your page or in your 

Web site. 

 Tip   You can customize your workspace by displaying additional toolbars or 

changing the buttons they contain. On the View menu, point to Toolbars, and 

then select the toolbars you want to display. To add or remove buttons from 

toolbars, click Customize.

Getting Started

For this tutorial, you’ll create a Web site with four pages, on which you will tell site 

visitors about a fictional sporting goods store. If the task of putting together a whole 

site seems daunting, don’t worry. You can gradually add information and other pages 

to your Web site. Unlike printed letters, memos, and word-processing documents, 

Web sites can be changed or updated even after they’ve been published. You can 

add, delete, and modify text, pictures, and entire pages at any time.

With FrontPage, you can get started by typing text on the blank document that Page 

view provides. For this lesson, we’ll begin with the home  default 

document that greets your visitors when they first navigate to your Web site.

To create a home page
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The home page is the front door to your Web site. It provides information about the 

content or subject matter of your site in order to spark interest in your site visitors. 

The home page also contains the links to the other pages in your Web site.

1. On the blank page in Page view, type Welcome to Championzone! and 

then press ENTER.

Just like in a word processor, pressing ENTER puts the cursor on a new line.

2. Next, type the sentence Take a look around to learn more about our 

sporting goods, see pictures of our merchandise, and look at our 

Sports Photo Gallery.

3. Press ENTER.

Most of the content for your Championzone site is already created. When 

you’re ready to make your own Web site, FrontPage lets you import any of 

your existing documents directly onto your Web pages without having to 

retype anything.

Your page should now look like this:

Next, you will add a picture to the Web page. Pictures can be scanned photographs, 

drawings, or computer graphics created in a drawing or image-editing program.
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For this example, the picture you’ll insert is a graphic of the FrontPage logo:

To insert a graphic on the home page

1. On the Insert menu, point to Picture, and then click From File.

FrontPage displays the Picture dialog box.

Note   The picture file you’ll insert is located in the Tutorial folder that was 

installed with the FrontPage program files.

2. Next to Look In, select the hard disk where you installed the tutorial.

You most likely installed the tutorial on your C or D drive.

3. Navigate to the folder named FPTutor2002 by double-clicking each folder in 

this path until the Look in box displays FPTutor2002.

You will see several files in the FPTutor2002 folder. By default, FrontPage 

searches for picture files when you are inserting a picture.

4. Click the file named frontpage, and then click Insert.

FrontPage inserts the selected picture file on the current page. It is a graphic 

that your site visitors will be able to click to learn more about FrontPage 

2002.

5. Press ENTER to create a new line.

Your page should now look like this:
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Merely inserting a picture of a button doesn’t mean that anything will happen when 

someone clicks it in a Web browser. To make a picture or a word clickable, it must 

have a hyperlink associated with it.

A hyperlink is a pointer from text or from a picture to another page or file on the 

World Wide Web or on an intranet. On the World Wide Web, hyperlinks are the 

primary way to navigate between pages and other Web sites.

In the next steps, you’ll create a hyperlink from the graphic you just placed on the 

home page.

To create a hyperlink from a picture

1. On the home page, click the picture of the FrontPage 2002 button you 

inserted.

When a picture is selected, it is shown with file  small 

squares around the outline of the picture. These can be used to resize a 

picture or change its appearance. When a picture is selected, FrontPage also 

displays the Pictures toolbar. The Pictures toolbar provides picture editing 

and formatting tools, which you’ll learn about later.

Note   If the Pictures toolbar doesn’t appear automatically, on View 

menu, point to Toolbars, and then click Pictures.

2. On the Insert menu, click Hyperlink.

FrontPage displays the Insert Hyperlink dialog box. Here, you specify the 

target of the hyperlink you are creating.

3. In the Address box, type www.microsoft.com/frontpage.

Notes

o Notice that FrontPage automatically adds an HTTP prefix. HTTP stands 

for Hypertext Transfer Protocol. This is the Internet protocol that 

allows World Wide Web browsers to retrieve information from Web 

servers.

o Because you’re creating a hyperlink from a button that is labeled 

Microsoft FrontPage, you’ll link to the FrontPage home page on the 

World Wide Web. When site visitors click the button in their Web 

browser, they will be taken to the Microsoft FrontPage home page.

4. Click OK to finish creating the hyperlink.

You may notice that the appearance of the button itself hasn’t changed. Unlike text 

hyperlinks, which are generally blue and underlined, picture hyperlinks do not 

automatically indicate the presence of the hyperlink. This is intentional, because 

changing the appearance of the picture could obscure the intended page design in 

some cases.
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You can quickly check the existence of a hyperlink from a picture by moving the 

mouse pointer over the picture. If a hyperlink is present, FrontPage displays the URL 

of the hyperlink in the status bar.

Next, you’ll insert a picture of the Championzone logo at the top of the page.

Insert a picture on the home page

1. Press CTRL+HOME to quickly jump to the beginning of the current page.

 Tip   The key combination CTRL+HOME places the cursor in the home 

 top left margin on the current page.

2. On the Insert menu, point to Picture, and then click From File.

This time, FrontPage immediately displays the contents of the FPTutor2002 

folder. For the duration of each work session, FrontPage remembers the names 

and locations of the folders you’ve already navigated to.

3. Double-click the file named czlogo.

FrontPage inserts the graphic on the current page.

4. Press ENTER to move the welcome text to the line below.

Your page should now look like this:

To finish the home page, you’ll center the text and pictures on it.

To center elements on a page

1. On the Edit menu, click Select All.
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FrontPage selects everything on the current page.

2. On the Format menu, click Paragraph.

FrontPage displays the Paragraph dialog box. Here, you can change the 

alignment of selected elements, and apply indentation and custom spacing for 

text and graphics.

3. In the Alignment list, click Center, and then click OK.

FrontPage centers the text and the pictures on the home page.

4. Click anywhere on the page to deselect all page elements.

To save the current page

Now that you’ve invested some time and completed a number of steps, it’s a good 

idea to save your page.

1. On the File menu, click Save As.

FrontPage displays the Save As dialog box. Here, you can specify the location 

for the current page, and review or change the page title, the file name, and 

the file type.

2. In the Save As dialog box, click the My Documents icon on the vertical places 

bar.

The contents of your My Documents folder are displayed. If no files are 

displayed in the file list, then you currently do not have any other Web pages 

stored here.

3. Next to the Page title field, click the Change title button.

FrontPage displays the Set Page Title dialog box. Here, the default page title 

is based on the first line of text on the current page. A title identifies the 

contents of a page when it is displayed in a Web browser. For this tutorial, 

you’ll change the page title to something more descriptive.

4. In the Set Page title box, type Home Page and then click OK.

5. In the File name box, change the suggested text to homepage, and then click 

Save.

FrontPage saves the current page.
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Page View Options

While creating the home page, you’ve worked exclusively in normal Page view, but 

there are three different ways you can choose to look at the current page.

To display HTML tags on the current page

• In Page view , click Reveal Tags on the View menu.

• FrontPage displays graphical representations of standard HTML tags for the 

current page. This display is useful for people who want to know where HTML 

tags are placed while they design their pages.

• To hide the tags, click Reveal Tags on the View menu a second time.

To display the HTML of the current page

• In Page view, click the HTML button at the bottom of the page.

This causes FrontPage to display the HTML code that it has created so far 

while you were designing the home page. Web browsers decode these 

instructions to display the page. The HTML pane is intended for experienced 

Web developers and page designers who want to customize the HTML that 

FrontPage creates.

• If you want to set your preferences for the way FrontPage will generate HTML 

code, click Page Options on the Tools menu, and then click the HTML 

Source tab. If you’re not experienced in HTML, you don’t need to make any 

changes here. Click Cancel to close the Page Options dialog box.

• Click the Normal button at the bottom of the page to return to the Normal 

pane.

 Tip   While working in the HTML pane, you can use many menu commands and 

toolbar buttons just like in the Normal pane.

To preview the current page

• Click the Preview button at the bottom of the page.

Note   If you do not have Microsoft Internet Explorer installed on your 

computer, the Preview tab will not be displayed, and you will not be able to 

preview your pages this way. For more information, see Before You Begin.

Looking at your page in the Preview pane is a quick and convenient way to 

see how certain  animations, movie clips, tables, and 

 appear in a Web browser.
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• Click the Normal button at the bottom of the page to return to the Normal 

pane once again.
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Creating a Web site with FrontPage

A Web site is the collection of a home page and its associated pages, graphics, 

documents, multimedia, and other files. Web sites are stored on a Web server or on 

a computer’s hard drive. FrontPage-based Web sites also contain files that support 

FrontPage-specific functionality and allow Web sites to be opened, copied, edited, 

published, and administered with FrontPage.

In the previous procedures, you learned how easy it is to create a Web page with 

FrontPage. As soon as you start the application, you can start typing and editing, 

then save the document to your hard  like a word processor. While 

you can certainly choose to put together an entire Web site like this, it can take a lot 

of manual work and attention to detail to maintain hyperlinks and source files, and 

keep your content up to date.

When you save your pages to a Web site, FrontPage can automatically manage and 

repair hyperlinks, organize files and folders, maintain dynamic link bars, check 

spelling across all pages in the Web site, and generate reports that point out 

problems with your pages and files.

To create a new Web site

1. On the File menu, click Close to close the current page.

2. On the File menu, point to New, and then click Page or Web.

FrontPage displays the New Page or Web task pane. Here, you can choose 

from several Web site templates and wizards, specify where you want to save 

your Web site, and specify what you want to call it.

3. Under New from template, click Web Site Templates.

4. Click One Page Web, and then press TAB.

Pressing the TAB key moves the selection to the field where you specify the 

name and location of the new Web site.

5. In the Specify the location of the new Web box, change the suggested 

name to <drive>:\My Documents\My Webs\Championzone, and then 

click OK.

Notes

• <drive> represents your local hard disk, which is usually C:\ or D:\.

• FrontPage creates a new Web site named “Championzone,” and displays its 

name and location in the title bar at the top of the FrontPage program 

window.

• Because you’ll be working with several files in your Web site, FrontPage also 

displays the Folder List, where you can see the files and folders in your 
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current Web site, similar to files and folders in Microsoft Windows Explorer. 

You’ll learn how to use the Folder List later, in Lesson 2.

• The lessons in this tutorial are designed to be completed using FrontPage 

2002 on a computer running Microsoft Windows 98, Microsoft Windows 2000, 

or Microsoft Windows Millennium Edition. Depending on the operating system 

you’re using, you may notice minor differences in the user interface and the 

way folders are referenced.

6. If the Folder List is not showing, do the following:

• On the standard toolbar, click the arrow to the right of Toggle Pane , 

and then click Folder List.

7. Click the Navigation icon  on the Views bar.

When you have a Web site open, the icons on the Views bar let you look at the 

information in your Web site in different ways.

Navigation view shows a graphical representation of the structure of your Web 

site. Because you created a one-page Web site, FrontPage has automatically 

designated it as the Web site’s home  with a small icon of a 

house .

While in Navigation view, FrontPage also displays the Navigation toolbar. You 

can drag the Navigation toolbar anywhere on your screen.

Next to the Views bar, FrontPage displays the optional Folder List, just like it 

did in Page view.

In a moment, you’ll replace the new, empty home page with the one you created 

earlier in this lesson. First, however, you’ll create the structure for the other pages in 

the Championzone Web site.

Creating a Web site structure in Navigation view enables features such as page 

banners and navigation bars that are automatically updated whenever you change, 

add, or remove pages in your Web site. This makes it easy to change things around. 

You’ll learn more about these features later.

To create a navigation structure

1. In Navigation view, click New Page  on the standard toolbar.

FrontPage creates a new page labeled “New Page 1” below the home page. Pages 

in Navigation view aren’t the actual pages in the current Web site; they are 
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placeholders that point to them. This way, you can easily experiment with the 

structure and organization of a Web site before you create its content.

2. To quickly create the remaining pages, hold down CTRL on your keyboard and 

press N three times.

CTRL+N is a keyboard shortcut for the New Page command. FrontPage supports 

common Windows and Microsoft Office XP shortcut keys that help speed up 

repetitive tasks. The pages you just created appear below the home page, 

because the home page was selected when you issued the command.

Note   In Navigation view, the selected page is blue, while others are yellow.

3. With the home page still selected, press TAB.

Pressing the TAB key moves the selection to the next page in the structure and 

activates the page title for editing. It also selects the text representing the name 

of the page, so you can easily type a new name.

4. Type About Us, and then press TAB.

About Us is the page title of one of the pages you’ll create for the Championzone 

Web site.

5. Repeat the previous step with the other pages, renaming New Page 2 as 

Products, New Page 3 as Photo Gallery, and New Page 4 as Links.

6. Pressing ENTER after editing a page title saves the new title without selecting 

another page. To deselect all pages, click anywhere outside the pages in 

Navigation view.

Your screen should now look like this:
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You can quickly open a page in Page view for editing by double-clicking the page in 

Navigation view or in the Folder List (pages will not show up in the Folder List 

until you save them).

Next, you’ll replace the blank home page FrontPage created from the Web site 

template by importing the home page you created and saved to your My Documents 

folder earlier in this lesson.

To import a page into a Web site

1. In Navigation view, double-click index.htm to open it in Page view. 

FrontPage opens the blank home page that was created from the Web site 

template.

2. On the Insert menu, click File.

FrontPage displays the Select File dialog box. Here, you can insert Web 

pages, word-processing documents, text files, and other documents on the 

current page.

3. In the Select File dialog box, navigate to the My Documents folder if it’s 

not already showing.

4. Click the file named homepage, and then click Open.

FrontPage imports your previously saved home page to the current page.

5. To save the current page to your Web site, click Save  on the standard 

toolbar.

FrontPage displays the Save Embedded Files dialog box. Here, you can 

preview, rename, save, and update embedded files that the current Web 

site will use.

When you previously saved this page to the My Documents folder on your 

computer, FrontPage left the two pictures you inserted in their original 

 FrontPage Tutorial folder. The home page merely pointed 

to the picture files without copying them to the same folder the page was 

saved to. To keep Web sites portable, however, you should always keep 

associated pages and files as part of the Web site that uses them.

6. In the Save Embedded Files dialog box, click OK.

FrontPage saves the home page as Index.htm and saves copies of the 

embedded picture files to the current Web site.

 Tip   Home pages have reserved names. FrontPage will automatically name 

home pages one of two reserved names that you should not change unless you 

need to. If you are running local Web server software such as Internet 

Information Services (IIS) on your computer, the home page will be named 

Default.htm. If you do not have a local Web server installed, or when you save 
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a page to your local hard drive instead of a Web site on a Web server, the 

home page will be named Index.htm.

 These names are reserved for home pages because Web browsers will 

automatically look for them when a site visitor types the URL to your Web site 

without a specific page reference.
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Creating Web site Content

Now that the home page is part of the current Web site, you will create the content 

for the other pages in the Championzone Web site.

Edit the About Us page

1. Click the Navigation icon on the Views bar to switch back to Navigation 

view.

Notes

o The Folder List now shows the two picture files you saved to the 

current Web site. The file Index.htm is the new home page. You can 

later discard the remaining copy of the home page from your 

My Documents folder.

o In the Folder List, the file names of the other pages were 

automatically derived from the page titles you typed into the pages in 

Navigation view. For this tutorial, we won’t change the names.

2. Double-click the About Us page to open it in Page view.

This page will provide some background about your fictional company for 

site visitors. For this tutorial, we have provided this text for you, so you can 

simply insert it on the page without having to type it.

3. On the Insert menu, click File.

4. In the Select File dialog box, navigate to the folder named FPTutor2002 

by double-clicking each folder in this path until the Look in box displays 

FPTutor2002.

5. Click the Files of type list and click Text Files (*.txt) to display only text 

files.

FrontPage displays one file, called About. There is only one text file in this 

tutorial.

6. Click About in the list, and then click Open.

The text you are inserting isn’t saved in HTML format, so FrontPage displays 

the Convert Text dialog box to let you control how the text will be 

imported.

7. In the Convert Text dialog box, click Normal paragraphs with line 

breaks, and then click OK.

FrontPage imports the text file and places it at the insertion point on the 

About Us page.
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8. On the standard toolbar, click Save  to save changes to the About Us 

page.

9. Close the Folder List.

Next, you will prepare the page titled Products. It will tell site visitors about 

sporting goods sold by Championzone. On this page, you will also provide a 

feedback form that collects ideas from people browsing the Championzone Web 

site.

To edit the Products page

1. On the standard toolbar, click the arrow to the right of Toggle Pane , 

and then click Folder List.

2. Double-click Products.htm in the Folder List to open the page in Page 

view.

3. Click the arrow to the right of Toggle Pane, and then click Folder List to 

hide the Folder List.

4. On the Insert menu, click File.

5. In the Select File dialog box, click the Files of type list, and then click 

Rich Text Format (*.rtf) to display the formatted text file in the Tutorial 

folder.

FrontPage displays the file matching the criteria.

6. Double-click the file productinfo.

Because this type of file contains formatting, FrontPage automatically 

converts the formatted text to HTML format and inserts it on the page.

7. On the toolbar, click the Save button to save changes to the Products 

page.

Designing a Page

The About Us page will inherit its formatting from a graphical theme that you will 

apply to the Championzone Web site later, in Lesson 2. The Products page, 

however, requires some more design work.

To help the reader differentiate the paragraph headings, list of products, and event 

details that the text on this page talks about, you will add some pictures, format 

paragraph styles, and create a bulleted list.
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To create a bulleted list

1. With the Products page still displayed in Page view, find the words “Team 

Bag.”

If the entire product list is not visible, use the scrollbar to bring the entire list 

into view.

The list begins with “Team Bag” and ends with “Goal Netting.”

2. Click just to the left of the letter T in “Team Bag,” hold down SHIFT, click just 

after the word “Netting,” and then release SHIFT. This will select the entire list.

3. On the Formatting toolbar, click the Bullets  button.

FrontPage converts the selected text to a bulleted list.

4. Click anywhere on the page to deselect the list.

Your page should now look like this:

You can also create numbered lists with FrontPage. When you add new items to a 

numbered list, FrontPage automatically numbers them sequentially. You can add to 

bulleted and numbered lists by pressing ENTER after an item in the list. To end a list, 

press ENTER twice after typing the last list item.

Next, you will place four pictures on the current page and use positioning features in 

FrontPage to align the pictures with the paragraphs they are associated with. This 

will create a more interesting page layout.
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To position pictures with text

1. With the Products page still displayed in Page view, place your cursor after 

the text “Featured Items of the Week.”

2. Click Insert Picture From File  on the standard toolbar.

When you last inserted a picture, you did not have a Web site open, and 

FrontPage automatically displayed the Select File dialog box. Now that a Web 

site is open, FrontPage assumes you want to work with pictures that are 

already part of your Web site, and therefore displays the Picture dialog box.

Because you haven’t yet added the picture you want to the current Web site, 

click the drop-down menu next to Look in, and navigate to the FPTutor2002 

folder.

Note   The folder is located at <drive>:\FPTutor2002, where <drive> 

represents the hard disk where you installed the tutorial.

4. Click the file named FPTutor001, and then click Insert.

FrontPage inserts a picture of a soccer ball just after the text “Featured Items 

of the Week.”

5. Next, click the picture of the soccer ball to select it.

6. On the Format menu, click Position.

FrontPage displays the Position dialog box.

7. Under Wrapping style, click Right, and then click OK.

The picture is aligned with the right margin of the current page, and the 

bulleted list flows to the left of it.

8. On the toolbar, click the Save button to save changes to the Products page.

9. In the Save Embedded Files dialog box, click OK.
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Your page should now look like this:

You can either place pictures one by one in this way, or you can import the pictures 

you will use on your pages all at once. While importing single files is done in Page 

view, inserting a group of files or entire folders is done in Folders view.

To add a group of files to the current Web site

1. Click the Folders icon  on the Views bar to switch to Folders view.

Folders view is an expanded view of the Folders List that you have seen in 

Navigation and Page view. Similar to the way you look at files in Microsoft 

Windows Explorer, here you can view details about the files and folders in your 

Web site, and perform such file management tasks as adding, deleting, moving, 

copying, and renaming files.

2. On the File menu, click Import.

FrontPage displays the Import dialog box. Here, you can add files and folders 

from your local file system, a local area network, a company file server, or a 

resource on the Internet or World Wide Web, such as an FTP server.

3. In the Import dialog box, click Add File.

4. In the Add File to Import List dialog box, navigate to the folder named 

FPTutor2002.

Note   The folder is located at <drive>:\FPTutor2002, where <drive> 

represents the hard disk where you installed the tutorial.
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5. Next, click the Files of type list, and then click GIF and JPEG (*.gif, *.jpg) 

to display all picture files in the Tutorial folder.

6. Click the file named czbanner in the list to select it.

7. Next, hold down CTRL, and while doing so, click to select the files named 

FPTutor002, FPTutor003, FPTutor004, FPTutor005, and FPTutor006.

8. When the files are selected in the Add File to Import List dialog box, release 

CTRL, and then click Open.

FrontPage adds the pictures you selected to the list in the Import dialog box.

9. Click OK to import the listed files to the current Web site.

Now that the remaining pictures are added to your Web site, it’s time to finish the 

layout of the Products page.

To finish the page layout

1. Click the Page icon on the Views bar to return to Page view.

2. If the Folder List is open, close it so you will be able to see more of the page 

you’re working on.

To close the Folder List:

• On the standard toolbar, click the arrow to the right of the Toggle Pane 

, and then click Folder List.

2. On the Products page, place the insertion point after the sentence “PRODUCTS 

- SELECT FROM A HUGE RANGE OF GEAR” and then click the Insert Picture 

From File button on the toolbar.

3. In the Picture dialog box, note that your previously imported pictures are now 

available, and then select the file FPTutor002 from the list.

You can also insert clip art, or if you have a scanner or a digital camera, you 

can acquire original pictures from those sources.

4. Click OK to insert the picture.

5. Click the picture you just inserted, and then click Align Right  on the 

toolbar to position the picture in the right margin and make the text wrap 

around it.
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Your page should now look like this:

Positioning pictures and other page elements around text on your page makes for a 

more interesting design, much like pages in a magazine or newspaper. By positioning 

pictures in the margin, your page layout will be preserved even when the page is 

viewed at a different screen size and resolution in a Web browser.

To finish the Products page, you will create a feedback form so that you can 

interact with site visitors who want to participate. A feedback form can be used to 

collect comments and information from people visiting your Web site.

To create a feedback form

1. In Page view, press CTRL+END to quickly jump to the bottom of the current 

page, or scroll all the way down using the scroll bar.

2. On the new, blank line, type Give Us Your Feedback! and then press ENTER.

3. On the Insert menu, point to Form, and then click Textbox.

FrontPage inserts a new form with a text box on the current page. The dashed 

lines indicate the form’s boundary. By default, the new form also contains 

Submit and Reset buttons.

Next, you will customize the default form by adding more form-fields and form-

field labels, so site visitors know what kind of information you want them to enter.

To customize the form

1. Click on the Submit button, and then click Center  on the toolbar.

2. Press the left arrow to place the cursor before the Submit button, and press 

ENTER.



29

Pressing ENTER adds a blank line to the form.

3. Click the text box and press the back arrow to place the cursor at the beginning 

of the form.

4. On the first line, type Your Name: and then press SHIFT+ENTER.

Holding SHIFT while pressing ENTER creates a line break. Line breaks are useful 

for spacing lines of text more closely together than standard paragraph 

spacing.

4. Move the cursor after the text box, and press ENTER.

5. On the next line, type Your E-mail Address: and then press SHIFT+ENTER.

6. On the Insert menu, point to Form, click Text Box once more, and then press 

ENTER.

7. On the next line, type Your comments: and then press SHIFT+ENTER.

8. On the Insert menu, point to Form, and then click Text Area.

FrontPage inserts a scrolling text input field into the form.

9. Double-click the scrolling text box you just inserted.

FrontPage displays the Scrolling Text Box Properties dialog box. Here, you 

can change the appearance of the text box.

10. In the TextArea Box Properties dialog box, change the Width in characters 

to 30 and the Number of lines to 5, and then click OK.

The scrolling text box has increased in size, which will encourage site visitors to 

write more than just a few lines.

Now that your form and the Products page are finished, it’s a good idea to 

save your work.

Note   You can’t test your form until you publish your Web site. You’ll learn 

how to publish your Web site in Lesson 2.

11. On the toolbar, click the Save button to save changes to the Products page.
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Your page should now look like this:

Good work! The feedback form is finished and so is the Products page. In the next 

part of the lesson, we’ll add the last two  online photo gallery and a list 

of links to some sites on the World Wide Web.
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Creating a Photo Gallery

The World Wide Web has a graphical interface, so it’s no surprise that many popular 

Web sites feature photographs and other types of graphics. Scanners and digital 

cameras have become much more affordable, and many photo-developing services 

now offer pictures on CD-ROMs so you can share them online.

You’ve seen how easy it was to place pictures on Web pages using FrontPage. In this 

part of the lesson, you’ll create an online photo gallery.

A photo gallery is a web page that contains a collection of graphics arranged in a 

specific layout. For the Championzone Web site, you’ll create a gallery of sports 

photos.

FrontPage 2002 provides several layouts in which you can arrange your graphics. For 

this tutorial, we will use the Horizontal layout.

To edit the Photo Gallery page

1. On the toolbar, click the arrow to the right of Toggle Pane , and then click 

Folder List.

2. Double-click photo_gallery.htm in the Folder List to open the page.

3. Click the arrow to the right of Toggle Pane, and then click Folder List to hide 

the Folder List.

4. When the blank page is displayed in Page view, type Sports Photos on the 

first line, then press ENTER.

5. On the next line, type: Please enjoy our Sports Photo Gallery. Click each 

thumbnail to see the full-size picture, and then use your Web browser’s 

Back button to return to this page.

6. Press ENTER twice to create some space.

7. On the Insert menu, click Web Component.

8. In the left pane, click Photo Gallery.

9. In the right pane, select the first layout option (the Horizontal Layout), and 

then click Finish.

10. The Photo Gallery Properties dialog box automatically opens.

11. Click Add, and then click Pictures from Files.

12. Click the file FPTutor003, hold down SHIFT, and then click FPTutor006.

This will select FPTutor003, FPTutor004, FPTutor005, and FPTutor006.

13. Click Open, and then click OK.
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14. On the standard toolbar, click the Save button to save changes to the Photo 

Gallery page.

15. In the Save Embedded Files dialog box, click OK.

Your page should now look like this:
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Linking to Other Web Sites

Now only the Links page remains to be edited. For this tutorial, the Links page will 

contain a list of text hyperlinks to some popular sports pages on the World Wide 

Web.

When you create your own Web site, you can create hyperlinks pointing to other 

Web sites that relate to the subject matter of your own pages. This lets visitors 

browse to similar sites without having to search for them.

To begin the Links page

1. On the toolbar, click the arrow to the right of Toggle Pane , and then click 

Folder List.

2. Double-click links.htm in the Folder List to open the page in Page view.

3. Click the arrow to the right of Toggle Pane, and then click Folder List to hide 

the Folder List.

4. When the blank page is displayed in Page view, type Links to Sports Sites 

and then press ENTER.

Next, you will create a simple text animation of the paragraph heading. FrontPage 

includes a collection of fun text effects that you can easily apply to text headings or 

entire paragraphs.

To create a dynamic text effect

1. On the Links page, click anywhere in the text Links to Sports Sites.

2. On the Format menu, click Dynamic HTML Effects.

FrontPage displays the DHTML Effects toolbar. Here, you’ll make sequential 

selections that will create a simple dynamic HTML (DHTML) script to animate 

the text when it is displayed in a Web browser.

Dynamic HTML is an extension of the HTML language that lets you create 

presentation effects for text and objects, much like in a Microsoft PowerPoint® 

slide show. Using the DHTML Effects toolbar, you can add simple effects to 

your pages without the need to know programming.

3. In the On list, click Page load.

This will instruct the Web browser to begin the effect when the page loads.

4. In the Apply list, click Hop.

FrontPage applies the Hop effect. In a Web browser, this effect will cause each 

word to bounce onto the page.
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5. Click the Close box in the upper right corner of the DHTML Effects toolbar.

The DHTML Effects toolbar closes and the dynamic text effect is indicated in 

Page view with light blue shading.

 Tips

• If you have Microsoft Internet Explorer installed, you can click the Preview tab 

in Page view to see the effect as it will appear in a Web browser. Click Normal 

to return to Page view.

• To change the effect, in the Normal pane, select the text containing the effect, 

click Dynamic HTML Effects on the Format menu, and then apply the new 

effect you want.

Next, you will add text hyperlinks that point to other sites on the World Wide Web. 

With FrontPage, you can create text hyperlinks in a number of ways, which you will 

learn next. When you create your own Web sites, you can create hyperlinks using 

your preferred method.

To create hyperlinks from text

1. On the Links page, press the DOWN ARROW key, type MSN Sports and then 

press ENTER.

2. Click and drag the mouse over the words you just typed to select them.

3. On the Insert menu, click Hyperlink.

FrontPage displays the Insert Hyperlink dialog box. Here, you specify the 

target of the hyperlink you are creating. This can be a page or a file in your 

Web site, on your local file system, on a Web server, or on another site on the 

World Wide Web.

5. In the URL box, type www.msnbc.com/msn/msnsports_front.asp, and 

then click OK.

Notice that FrontPage automatically adds the HTTP prefix.

6. On your keyboard, press the DOWN ARROW key to deselect the text.

The words “MSN Sports” have changed from black default text to blue text, and 

the words are now underlined to indicate the presence of a hyperlink. When this 

page is displayed in a Web browser, clicking this hyperlink will retrieve and 

display the MSN home page.

Before creating the next hyperlink, you’ll insert a special character symbol to indicate 

a trademark on the current page.

To insert special characters or symbols
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1. Click to insert the mouse cursor just after the letters MSN in the hyperlink you 

just created.

2. On the Insert menu, click Symbol.

FrontPage displays the Symbol dialog box. Here, you can select and insert 

special characters at the insertion point. You can insert multiple symbols while 

this dialog box is displayed.

3. In the Symbol dialog box, select the ® symbol, click Insert, and then click 

Close.

FrontPage inserts the symbol after the letters MSN. You can use the Symbol 

command to insert characters that you may not be able to type directly with 

your keyboard.

Next, you will create an automatic hyperlink. This method of creating hyperlinks is 

quick and easy, because it lets you bypass the Create Hyperlink dialog box.

To create an automatic hyperlink

1. On the Links page, press the DOWN ARROW key, type 

www.sports.yahoo.com, and then press ENTER.

As soon as you press ENTER, the URL you typed changes from black to blue 

text and is underlined to indicate the presence of a hyperlink. Like other 

Microsoft Office XP programs, FrontPage supports automatic hyperlink creation. 

Since a URL by itself is not always very descriptive, however, you’ll want to 

change it to the name of the site that the hyperlink points to. You can overtype 

the text without erasing the hyperlink.

Note   Yahoo! is a popular Internet service that lets you look for information on 

the World Wide Web using search keywords and subject categories. This 

particular URL goes to the Yahoo sports page.

2. Using the mouse, click and drag over the URL you just typed to select it.

3. When the URL http://sports.yahoo.com is selected, type Yahoo! to replace 

the selected text.

The hyperlink still points to the same URL, but it is now labeled with the site’s name.

Next, you’ll create a hyperlink using your Web browser. This method of creating 

hyperlinks is the most accurate, because you actually visit the page the hyperlink will 

point to before creating the hyperlink. In addition, FrontPage copies the URL from 

the Web browser address field, so once the address is verified, you don’t have to 

type it again.

Note   If you do not have access to the World Wide Web while taking the FrontPage 

Tutorial, skip the following procedure and practice these steps the next time you’re 

connected to the Internet.
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To create a verified hyperlink

1. Press the DOWN ARROW key to move the insertion point to the blank line below 

the previous hyperlink.

2. Type National Basketball Association, and then press ENTER.

3. Click and drag the mouse over the words you just typed to select them.

4. On the toolbar, click the Hyperlink  button.

FrontPage displays the Insert Hyperlink dialog box.

5. In the Insert Hyperlink dialog box, click the Browse the Web  button.

FrontPage starts your Web browser. When you visit the page that the hyperlink 

should point to and then switch back to FrontPage, the URL box will contain the 

address of the target page.

6. In your Web browser’s Address (or Location) box, type 

http://www.nba.com, and then press ENTER.

The Web browser displays the National Basketball Association (NBA) home 

page, where you can learn more about the NBA, teams, players, schedules, and 

more.

7. On your keyboard, press ALT+TAB to switch back to the Create Hyperlink 

dialog box.

The URL of the Microsoft FrontPage home page is now entered into the URL box 

in the Create Hyperlink dialog box.

8. Click OK.

9. On your keyboard, press the DOWN ARROW key to deselect the text.

The words “National Basketball Association” are now underlined to indicate the 

presence of a hyperlink.

10. On the toolbar, click the Save button to save changes to the Links page.
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Your page should now look like this:

Formatting Paragraph Headings

Now that you have successfully created the content on all the pages in your Web 

site, you’ll apply paragraph and font formatting to make the paragraph headings on 

all pages look consistent.

To apply paragraph styles to headings

1. Click the page tab for index.htm.

FrontPage brings the home page back into view. When you have more than 

one page open in the Normal pane, you can use page tabs to switch between 

them.

Note   If you closed the page in a previous step, on the File menu, click 

Open, and then in the Open File dialog box, click index.htm.

2. Click anywhere in the heading Welcome to Championzone.

3. Click the Style list on the Formatting toolbar, and change Normal to 

Heading 3.

4. FrontPage applies the Heading 3 style to the current line of text. The size of 

the text isn’t affected, but the text is now bold.
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5. Heading styles in the Style list are based on HTML standards. A level 1 

heading is the largest possible text style for Web pages, and a level 6 heading 

is the smallest.

Note   The Style list can also contain styles from cascading style sheets 

(CSS), but CSS is not covered in this tutorial.

6. On the toolbar, click the Save button to save the home page.

7. Click the Page tab for About_Us.htm.

FrontPage brings the About Us page back into view.

8. Click anywhere in the heading About Us at the top of the page.

9. Click the Style list on the toolbar, and then click Heading 4.

10. On the toolbar, click the Save button to save changes to the About Us page.

To repeat paragraph formatting with the Format Painter

FrontPage provides a convenient way to copy the formatting styles from one 

selection of text to another with the push of a button. You’ll practice how to do this 

on the Products page.

1. Click the Page tab for Products.htm.

FrontPage brings the Products page back into view.

2. Click anywhere in the text PRODUCTS – SELECT FROM A HUGE RANGE OF 

GEAR at the top of the page.

3. Click the Style list on the toolbar, and then click Heading 4.

4. When the style has been applied, click anywhere in the sentence, and then click 

Format Painter  on the Formatting toolbar.

5. Using the scroll bar, scroll down to the heading Give Us Your Feedback.

6. Click the mouse to drag the Format Painter pointer  over the words Give 

Us Your Feedback, and then release the mouse button.

FrontPage copies the formatting from the previous heading and applies it to the 

current heading. The Format Painter tool is particularly useful when you want to 

concurrently duplicate several formatting choices from one selection of text to 

another.

7. On the toolbar, click the Save button to save the Products page.

 Tip   You can repeat text formatting over more than one selection of text by 

double-clicking the Format Painter button after selecting the format you want 
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to copy. Select the various text locations you want to copy the formatting to, 

and then click the Format Painter button again when you’re finished.

Next, you’ll finish formatting the page headings on the remaining two pages.

To finish applying paragraph styles to headings

1. Click the Page tab for photo_gallery.htm.

FrontPage brings the Photo Gallery page back into view.

2. Click anywhere in the heading Sports Photos at the top of the page.

3. Click the Style list on the toolbar, and then click Heading 4.

4. On the toolbar, click the Save button to save the Photo Gallery page.

5. On the Window menu, click links.htm.

6. Click anywhere in the sentence Links to Sports Sites.

7. Click the Style list on the toolbar, and then click Heading 4.

8. On the toolbar, click the Save button to save the Links page.

Congratulations! You’ve successfully completed Lesson 1.

What’s Ahead

In Lesson 2, you’ll enhance the appearance of the Championzone Web site by adding 

shared borders, navigation bars, and a graphical theme, and you will learn how to 

preview, test, organize, and publish the finished Web site.

Finishing Lesson 1

You can continue with Lesson 2 now, or close Microsoft FrontPage and continue the 

tutorial at a later time.

To close Microsoft FrontPage

• On the File menu, click Exit.

FrontPage closes.
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Lesson 2  Enhancing and Publishing a Web site

In Lesson 1, you learned how to create Web pages with Microsoft FrontPage and then 

add them to a new Web site.

In this second lesson, you’ll continue working with the Championzone Web site you 

created by adding navigation bars to its pages, applying and customizing a graphical 

theme, previewing and testing the Web site, and then preparing the Web site for 

publication on the World Wide Web.

Before you publish a Web site, you’ll want to make sure its pages and files are well 

organized, all of its hyperlinks are working, pages are free of spelling errors, and you 

have enough space available on the target Web server. FrontPage can help you 

complete these important tasks.

Overview

In this lesson, you will learn how to:

• Create hyperlinks to other pages within a Web site.

• Add shared borders and navigation bars.

• Apply and customize a graphical theme.

• Preview and test a Web site in a Web browser.

• Organize files and folders.

• Generate a Site Summary report.

• Check spelling on a page and across a Web site.

• Replace text on Web pages.

• Publish a Web site to the World Wide Web.

Enhancing the Appearance of a Web site

If you’re continuing this lesson directly from Lesson 1, the Championzone Web site 

should still be open in FrontPage. If this is the case, skip down to the procedure 

named To create hyperlinks to other pages.

If you’re continuing this tutorial from a previous session, then you must first open 

the Web site before you can work with its pages.

To open an existing Web site

1. On the Windows taskbar, click the Start button, point to Programs, and then 

click Microsoft FrontPage.

2. On the File menu, point to Recent Webs, and then click Championzone to 

open the Championzone Web site you created in Lesson 1.

FrontPage opens the Web site. The application title bar now reads Microsoft 

FrontPage – <drive>:\My Documents\My Webs\Championzone.

The lessons in this tutorial are designed to be completed using FrontPage 2002 

on a computer running Microsoft Windows 98, Microsoft Windows 2000, or 
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Microsoft Windows Millennium Edition. Depending on the operating system 

you’re using, you may notice minor differences in the path to your Web site.

While creating hyperlinks from pictures and text in Lesson 1, you may have noticed 

that you don’t have any connections yet between the pages in your Web site. Even if 

someone visited your current home page, they would have no way of getting to the 

other pages. In the next section, you’ll learn how easy it is to make navigation 

hyperlinks to other pages.

To create hyperlinks to other pages

1. On the toolbar, click the arrow to the right of Toggle Pane , and then click 

Folder List.

You’ll keep the Folder List visible while you create hyperlinks to the other 

pages in your Web site.

2. Double-click index.htm in the Folder List to open the home page in Page 

view.

3. When the home page is displayed in Page view, press CTRL+END to place the 

cursor at the end of the home page.

4. Next, locate the page About_Us.htm in the Folder List.

The folders and files in the Folder List are shown in alphabetical order. The 

icon of each file gives you a clue about what kind of file it is.

You will now drag and drop the About Us page onto the bottom of the home 

page. When you do this, FrontPage will create a hyperlink to the About Us 

page on the home page.

5. Click and hold the mouse button on About_Us.htm in the Folder List, move 

the mouse pointer on the line below the FrontPage button at the bottom of the 

home page, and then release the mouse button.

FrontPage displays the shortcut mouse pointer while you drag the mouse to 

indicate that it will not actually insert the About Us page, but will create a 

hyperlink pointing to it.

FrontPage inserts the page title of the About Us.htm file (“About Us”) as the 

hyperlink text. The blue underlined text shows the presence of the hyperlink.

6. Repeat steps 4 and 5 with the other pages in the Championzone Web site, 

including Products.htm, Links.htm, and Photo_gallery.htm. Place each link 

just after the previous one.

7. On your keyboard, press the DOWN ARROW key to deselect the last hyperlink.

Your page should now look like this:
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While you can manually create hyperlinks to the other pages in your Web site this 

way, doing so for all pages in a Web site can become a time-consuming and tedious 

task, especially for larger Web sites. Worse, if you decide to add or remove pages in 

the current Web site after creating hyperlinks, you’ll have to manually add or remove 

the hyperlinks to them.

FrontPage has a better way to create, manage, and automatically update the 

navigation hyperlinks that connect your pages together. Before you learn how to do 

this, let’s get rid of the four hyperlinks you just made.

To use the multiple Undo command

1. On the standard toolbar, click the small arrow just to the right of the Undo 

 button.

2. FrontPage displays the Undo history, which shows the last several actions you 

can reverse. The first of these actions is selected by default. If you were to click 

it, then only that action would be reversed. You can also move the mouse over 

other entries in this list to include them in the Undo command.

3. Since we want to get rid of all four hyperlinks you just dragged and dropped 

onto the home page, move the mouse down the list to select all four 

occurrences of Drop.

The status bar in the Undo history window should read Undo 4 Actions.

4. Click the mouse on the last occurrence of Drop in the list.

FrontPage reverses the last four actions you took, and the four hyperlinks you 

created are removed from the home page.

5. To save the current page, click Save on the File menu, or click the Save 

button on the toolbar.
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Adding Shared Borders and Navigation Bars

For the Championzone Web site, you will let FrontPage manage the hyperlinks that 

site visitors will click to move around the pages in your Web site. FrontPage achieves 

this with a combination of two powerful features: shared borders and automatic 

navigation bars.

Shared borders are page regions reserved for content that you want to appear 

consistently throughout the pages in your Web site. These borders can contain page 

banners and navigation bars. Page banners display the page title you gave each 

page when you created or saved it. Navigation bars are a row or column of 

hyperlinks to the other pages in the current Web site. FrontPage can automatically 

update shared borders and navigation bars, so the navigation structure of your Web 

site will always work correctly, even when you add, move, or delete pages from the 

Web site’s structure.

In Lesson 1, you already completed the first step required for automatic navigation 

bars: creating the basic Web site structure in Navigation view. Because you have 

already done this, you’ll now enable shared borders throughout your Web site.

To create shared borders across a Web site

1. Click the Navigation icon on the Views bar to switch to Navigation view.

2. Click the arrow to the right of Toggle Pane , and then click Folder List to 

hide the Folder List in this view.

3. On the Format menu, click Shared Borders.

FrontPage displays the Shared Borders dialog box. Here, you can specify 

where on your pages FrontPage should insert shared borders. Because your 

Web site structure has two levels of  home page and the pages 

below  will use two kinds of shared borders and two kinds of 

navigation bars.

4. In the Shared Borders dialog box, make sure the All pages option is 

selected.

5. For a horizontal shared border, select the Top check box and select the 

Include navigation buttons check box just below it.

6. For a vertical shared border, select the Left check box and select the Include 

navigation buttons check box below it.

7. Leave the Right and Bottom check boxes unchecked, and then click OK.

FrontPage creates shared borders and default navigation bars for all the pages 

in the current Web site. You’ll see what these look like when you return to 

Page view.
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Next, you’ll customize the appearance of the default navigation bars. Because they 

are shared across all pages in the current Web site, you can change their properties 

on any page and the change will be reflected across the entire Web site.

To test link bar hyperlinks

1. In Navigation view, double-click the Home Page (index.htm).

2. Click the arrow to the right of Toggle Pane , and then click Folder List to 

hide the Folder List in Page view.

Note   FrontPage has made changes to the home page. It now contains a top 

and left shared border. The top border contains a page banner with the name of 

the current page, and the left border contains a list of navigational hyperlinks 

that look exactly like the ones you manually created at the beginning of this 

lesson.

In Page view, you can easily test hyperlinks that point to pages and files in 

your Web site.

3. Hold down CTRL and then click the first navigational hyperlink named About 

Us on the left side of the page.

FrontPage opens the page the hyperlink points to. On the About Us page, 

shared borders and navigation bars have also been inserted. On this page, 

however, the links to the other pages are displayed in the top border, just 

under the page banner. This is because FrontPage uses the Web site structure 

you created in Navigation view to determine the level the current page is on.

By default, the top shared border points to pages on the same level as the 

current one, whereas the left border points to pages below the current one. In 

the next section, we’ll change this default to another design.

To customize link bars

1. Click the page tab for index.htm.

FrontPage brings the home page back into view.

2. In the top border of the home page, double-click the text that reads Edit the 

properties for this Link Bar to display hyperlinks here.

Double-clicking a link bar opens the Link Bar Properties dialog box. Here, 

you can customize the appearance of a link bar and the hyperlinks it creates.

Currently, the horizontal link bar is set to link to pages on the same level. 

Since the home page is on its own level in your navigation structure of your 

Web site, there are no other pages on the same level. FrontPage therefore 

doesn’t show any link bars in this shared border.

For the Championzone Web site, we want to have a horizontal link bar on the 

home page and vertical navigation bars on the other pages. To do this, we’ll 
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change the default setup of both link bars. You can make these changes on 

the current page and they’ll be reflected throughout your Web site.

3. In the Link Bar Properties dialog box, click Child level, clear the check 

boxes for Home page and Parent page, and then click OK.

FrontPage creates a navigation bar with hyperlinks to all the pages below the 

home page level.

4. Press HOME to deselect the navigation bar.

Your page should now look like this:

Note that the left navigation bar still contains the same set of hyperlinks as 

the top navigation bar. In the next steps, you’ll remove the obvious 

redundancy and format the left navigation bar so it is displayed only on the 

other pages that the home page points to.

5. In the left border of the home page, double-click the vertical navigation bar.

6. In the Link Bar Properties dialog box, click Same level, select the Home 

page check box, and then click OK.

FrontPage changes the navigation bar to the placeholder text that reads Edit 

the properties for this link bar to display hyperlinks here. This text is 

only shown in Page view while you work; it will not appear in a Web browser.

By pointing the hyperlinks in this navigation bar to the same level as the 

home page, you are effectively removing the hyperlinks from the left border, 

because there are no pages on the same level as the home page. This also 

removes the redundancy between the horizontal and vertical navigation bars.
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7. To save the home page, click Save on the File menu, or click the Save 

button on the toolbar.

Your page should now look like this:

8. On the Window menu, click About_Us.htm.

9. FrontPage brings the About Us page back into view.

Note that the changes you’ve made on the home page to both the horizontal 

and vertical navigation bars are automatically reflected here, as well as on all 

the other pages in your Web site.

 Tip   By default, all pages in your Web site’s navigation structure are 

included in navigation bars. You can select pages to be excluded from your 

navigation bars by right-clicking the page in Navigation view and clicking 

Included in Navigation Bars on the shortcut menu.
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Applying a Theme

Although the addition of pictures, lists, forms, shared borders, and navigation bars 

has given the pages in the Championzone Web site a more streamlined and 

organized look, you may wonder what to do about the rather bland appearance of 

black and blue text on a white background.

Imagine how time-consuming it would be if you had to design a color scheme for 

text and graphics, and create graphical page banners, navigation buttons, list 

bullets, and background textures for all the pages in your Web site. Now imagine 

how many more custom graphics you would need to create if you maintained more 

than one Web site and you didn’t want any of your Web sites to look the same.

FrontPage includes more than 50 professionally designed themes with matching color 

schemes that you can apply to any or all pages in your Web site. A theme consists of 

design elements for bullets, fonts, pictures, navigation buttons, and other graphics. 

When applied, a theme gives pages, page banners, navigation bars, and other 

elements of a Web site an attractive and consistent appearance.

To apply a theme to the Web site

1. Click the Page tab for index.htm.

FrontPage brings the home page back into view.

2. On the Format menu, click Theme.

FrontPage displays the Themes dialog box. Here, you can select from a list of 

themes that FrontPage installed by default, or choose to install the complete set 

of themes from your FrontPage CD-ROM. You can make choices about the 

appearance of the theme, preview theme elements, and modify the selected 

theme.

3. Click on some of the different theme names in the scrolling list box.

When you click the name of a theme, the Sample of Theme window shows a 

sample of the graphical elements that are contained in the selected theme. This 

way, you can first preview a theme before applying it to select or all pages in 

your Web site.

Before applying a theme, you can select theme options that affect the 

appearance of the theme’s components. For example, selecting Vivid colors 

applies brighter colors to text and graphics, selecting Active graphics 

animates certain theme components, and selecting Background picture 

applies a graphical background to the pages in your Web site. You can also 

choose to apply a theme as a cascading style sheet.

For the Championzone Web site, you’ll clear most of these defaults.

4. Under Apply theme to, make sure All pages is selected.

5. In the list of installed themes, click Blends.
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6. Clear the check box for Active graphics, then click OK to apply the theme.

Since this is the first time you’re applying a theme to a Web site, FrontPage 

displays a message to let you know that applying a theme will overwrite some 

of the manual formatting you may have done on your pages.

We’ve purposely not included much manual design work in this tutorial, so you 

can acknowledge this message and proceed to apply the theme.

7. Click Yes to apply the theme.

The theme named Blends is applied to all the pages in your current Web site.

To save the home page, click Save on the File menu, or click the Save button 

on the toolbar.

Your page should now look like this:

As you can see, applying the theme has dramatically changed the appearance of the 

home page. The page banner and navigation buttons are no longer plain text; now 

they’re graphics.

To display graphical navigation buttons on all pages

1. On the Window menu, click About_Us.htm.

FrontPage brings the About Us page back into view.

Note that the page has inherited its theme and theme elements from the home 

page, but the vertical navigation bar in the left border still shows plain text 

hyperlinks. By default, vertical navigation bars are displayed as plain text, so 

they look this way even after you apply a theme. You can easily change 

navigation bar settings even after a theme is applied.
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2. In the left border of the About Us page, double-click the vertical navigation 

bar.

5. On the Style tab, under Choose a style, click Use Page’s Theme, and then 

click OK.

If you don’t see Use Page’s Theme, scroll to the top of the list of styles.

6. Click anywhere on the page to deselect the navigation bar.

FrontPage changes the navigation formatting and uses the graphical buttons 

included with the theme. The Web site now has an attractive and professional 

look.

5. To save the page, click Save on the File menu, or click the Save button on the 

toolbar.

 Tip   Some themes contain animations. When you apply a theme, you can 

select Active graphics to enable page banner animations and navigation 

bar rollover effects, if the theme contains such elements. The theme 

sample will not show you what these effects look like. To see a theme’s 

active graphics effects, apply the theme and then display the page in the 

Preview tab, or click the Preview in Browser command on the File 

menu.

Modifying a Theme

Although the page banner of this theme looks nice, something directly related to the 

subject matter of the Championzone Web site might fit better. We’ve prepared a 

custom page banner with which you will modify the current theme.

To modify a theme

1. Click the Page tab for index.htm.

FrontPage brings the home page back into view.

2. On the Format menu, click Theme.
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FrontPage displays the Themes dialog box. In the list of themes, the Blends 

theme is now the default theme because it has been applied to the current Web 

site.

3. In the Themes dialog box, make sure All Pages is selected.

4. Next, click Modify.

5. Under the question What would you like to modify? click Graphics.

FrontPage displays the Modify Theme dialog box. Here, you can supply 

custom graphics for various theme elements such as page banners, navigation 

buttons, background pictures, and other elements. FrontPage superimposes 

text over these graphics, so there is no need to change graphics when you 

change the names of your pages, or add or remove pages.

For this example, we will change the graphical page banner on which FrontPage 

places the titles of the pages in the Championzone Web site.

6. In the Item list, click Banner.

7. On the Picture tab, click the Browse button below the file name of the current 

banner graphic.

FrontPage displays the Open File dialog box and shows the pictures in your 

current Web site. Since the graphical banner we want to use isn’t part of the 

Web site yet, you will search your file system for it.

8. Navigate to the folder named FPTutor2002.

9. Double-click the file czbanner.

FrontPage replaces the current page banner graphic with the custom graphic.

10. Click OK in the Modify Theme dialog box, and then click OK in the Themes 

dialog box.

FrontPage displays a message asking you whether you want to save changes to 

the current theme.

11. Click Yes.

FrontPage displays the Save Theme dialog box with the message This theme 

is read-only. Please enter a new theme title to save as:.

12. Enter Championzone as the title of the modified theme, and then click OK.

13. Click Yes to apply the theme.

FrontPage saves the modified theme and applies the new banner to all pages.

14. To save the page, click Save on the File menu, or click the Save button on the 

toolbar.
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Your page should now look like this:

 

 

 Tip   For this tutorial, we’ve provided only a custom page banner to help 

show you how easy it is to customize existing themes. To create your own 

designs, repeat the steps in the previous procedure to customize other 

theme elements with your own custom graphics.

Congratulations, the Championzone Web site is almost finished! To make sure 

everything will look great on the World Wide Web, you’ll now preview the Web site in 

your Web browser.
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Previewing the Championzone Web site

Although Page view shows you the appearance of your Web pages as closely as 

possible to how they will appear in a Web browser, it displays some page elements 

and placeholders differently to help you while you design the page. By previewing a 

page or your entire site in a Web browser before you publish the Web site, you can 

make sure that everything looks the way you want it to.

To preview the current Web site in a Web browser

1. On the File menu, click Preview in Browser.

FrontPage displays the Preview in Browser dialog box. Here, you can select 

from the installed Web browsers on your computer, add Web browsers you 

installed after installing FrontPage, and select the Web browser window size in 

which you want to preview your Web site.

 The Preview in Browser feature loads the current page in your Web browser, 

so you can see exactly how the page will appear in your favorite Web browser 

before you publish your Web site. You must have at least one Web browser 

installed on your system for this feature to work.

2. In the Preview in Browser dialog box, click Microsoft Internet Explorer, and then 

click Preview.

FrontPage launches the Web browser and opens the home page.

Your screen should now look like this:

Note that all placeholder text and formatting marks are hidden from view (for 

example, the empty vertical navigation bar on the left side of the home page 

does not appear).
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3. Click the buttons on the navigation bar to preview some of the other pages.

Note the vertical navigation bar on the pages below the home page. On the 

Products page, scroll down to the feedback form you added to the page. You 

can enter text in the fields, but the form won’t actually work until you publish 

the Championzone Web site to a Web server.

On the Photo Gallery page, click the picture thumbnails to test the hyperlinks 

to the full-size pictures. Use your Web browser’s Back button to return to the 

Photo Gallery page. Finally, on the Links page, note the dynamic animation of 

the paragraph heading that reads “Links to Related Sites.”

4. Close your Web browser when you have finished previewing the Championzone 

Web site.
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Organizing the Files in your Web site

Now that your Web site contains several pages and files, you will use Folders view 

to organize them. Similar to Windows Explorer, Folders view lets you manage the 

files and folders in your Web site. You can safely rearrange the pages and files in 

your Web site without breaking hyperlinks, page banner titles, or navigation button 

labels.

In Folders view, FrontPage displays a hierarchical list of the folders in your Web site 

on the left side of the screen. Clicking on a folder in the Folder List displays its 

contents on the right  Contents pane.

In the following steps, you will move all the picture files in the Championzone Web 

site to the Images folder FrontPage created as part of the Web site.

If you were to use Windows Explorer or another file manager to move pages and files 

from one folder to another, you would break the hyperlinks between your pages and 

page elements. However, when you maintain your Web site in Folders view, 

FrontPage keeps every page and hyperlink in your Web site updated to keep track of 

the new locations of files and folders that have been moved.

To move picture files to the Images folder

1. On the Views bar, click the Folders icon .

FrontPage switches to Folders view.

2. In the Folder List pane, click the top-level folder labeled 

<drive>:\My Documents\My Webs\Championzone.

This will ensure that the contents pane displays all of the folders and files 

contained in the root Web site.

3. In the Contents pane, click the Type column label.

Clicking on a column label sorts the files in the Contents pane by that 

criterion. The first time you click a column label, the list is sorted in ascending 

order; when you click it a second time, it is sorted in descending order.
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The list of files is now grouped by file type, with all GIF picture files at the top 

of the list, followed by HTM files (pages) in the middle, and all JPG pictures at 

the bottom of the list.

4. In the Contents pane, click the first picture file (czbanner) at the top of the 

list to select it.

5. Next, while holding down SHIFT, click the last GIF picture file in the list 

(frontpage.gif).

In Folders view, FrontPage supports all standard Windows selection shortcuts, 

such as SHIFT+CLICK for selecting ranges of files, and CTRL+CLICK for 

selecting noncontiguous files.

6. Click and hold the right mouse button while the pointer is over any of the 

selected GIF file icons.

7. Next, drag the mouse pointer over to the Images folder in the Folder List 

pane.

8. When the Images folder is selected, release the mouse button and click Move 

Here on the shortcut menu.

FrontPage displays the Rename dialog box while it is moving the selected GIF 

image files to the Images folder because it is automatically updating all 

hyperlinks to these files in the current Web site.

9. Repeat steps 4 through 8 with all JPG picture files, starting with 

FPTutor003.jpg and ending with FPTutor006.jpg.

10. In the Contents pane, click the Name column label to arrange the remaining 

list of folders and files by their name again.

You’ve successfully grouped all picture files in the Images folder.

When you work with your own Web sites, you can group sound files, movie clips, and 

other types of files in their own folders. You can create new folders in Folders view 

as needed and delete the ones you no longer need.

To create a new folder

1.  In the Folder List, click the folder in which you want to create a new subfolder.

Folders can be expanded and collapsed in the Folder List to bring their 

subfolders into view. Click the plus (+) and minus (-) signs next to a folder’s 

name to display or hide its subfolders.

2. On the File menu, point to New and then click Folder.

FrontPage creates a new folder with a temporary name.
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3. When the folder’s temporary name (New_Folder) is selected, type a new 

name for the folder, then press ENTER.

The new folder is renamed, and you can now drag and drop files into it.

For this tutorial, we don’t need the extra folder you just created, so you will 

delete it before we get ready to publish the Web site.

4. In the Folder List, right-click the folder you just created.

5. On the shortcut menu, click Delete.

6. In the Confirm Delete dialog box, click Yes.

FrontPage removes the folder from the Web site.

Generating a Site Summary

Reports view is an important tool that shows you the overall health and condition of 

your Web site before you publish it to the World Wide Web. You can generate custom 

reports about your Web site in up to 14 categories.

To generate a Site Summary report

• On the Views bar, click the Reports icon .

FrontPage switches to Reports view. The default report is the Site Summary. 

This report shows you the overall statistics of the pages and files in the 

Championzone Web site. Here are some important ones to look at before you 

publish your Web site:

• All files: You currently have 23 files in your Web site, totaling approximately 

435 KB. This is the amount of space you’ll need to have available on the Web 

server that will host your Web site.

• Slow pages: This category shows pages that are slow to download at the 

targeted download speed.

• Broken hyperlinks: If any broken hyperlinks are reported here, double-click 

the Broken hyperlinks row to view details about this category. FrontPage 

lists unverified hyperlinks, such as the external hyperlinks on your Links 

page, and links that are broken and do not work.

• Functioning hyperlinks: You can verify that a hyperlink still points to an 

active Web site by right-clicking the link in Reports view and choosing Verify 

from the shortcut menu. To fix a broken hyperlink, you must open the page it 

is on and repair the URL the hyperlink points to.
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Spelling Checking

Spelling checks are important if you want your Web site content to give visitors a 

professional impression. If words are misspelled on a single page, people might 

question the accuracy of your entire Web site content. The flexible spelling features 

in FrontPage give you the option of checking spelling page by page as you create and 

edit content, or doing it all at once, just before you publish your Web site to the 

World Wide Web.

There are three ways FrontPage can check spelling for you:

• Automatic spelling check as you type text

• Manual spelling check of the current page

• Cross-Web site spelling checks of all pages in a Web site

Automatic spelling check   In Page view, FrontPage automatically checks the 

spelling of text you type on the current page, just like Microsoft Word, Microsoft 

PowerPoint, and other Microsoft Office XP programs do. An underlined word doesn’t 

necessarily mean the word is spelled incorrectly. FrontPage may simply prompt you 

to verify unknown or suspected words, which happens most commonly with names 

of people and places.

If you know that the spelling of a suspected word is correct, you can either choose to 

ignore such words and keep them unchanged, or add them to a custom dictionary 

that FrontPage will keep for subsequent spelling checks. If the word is indeed 

misspelled, you can quickly insert the corrected spelling by right-clicking the 

suspected word and selecting a suggested correction.

Manual spelling check   Page-based spelling checks are available in Page view by 

right-clicking suspect words or by clicking the Spelling command on the Tools 

menu. 

Cross-Web site spelling check   While you can use automatic background spelling 

checking and per-page spelling checking in Page view, using the Spelling command 

in any other Web site view lets you check the spelling of all (or selected) pages 

across the current Web site. Cross-Web site spelling checks are available in every 

Web site view.

You can check the spelling of page elements that can be edited directly on the page. 

Other text, such as page titles in page banners or text contained in FrontPage-based 

components, are not included in the spelling check.

To check spelling in the current Web site

1. On the Tools menu, click Spelling.

FrontPage displays the Spelling dialog box. Here, you can specify whether 

FrontPage should check the spelling of selected pages only, or of the entire Web 

site.

2. In the Spelling dialog box, click Entire Web, and then select the Add a task 

for each page with misspellings check box.
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FrontPage will add a task to the Tasks list for each page on which misspelled 

text is found. You will learn about Tasks view in the next section.

3. In the Spelling dialog box, click Start to begin the spelling check.

FrontPage expands the Spelling dialog box to display the progress of the 

spelling check.

When the operation has been completed, FrontPage displays the misspelled 

words and the number of tasks that were added to the Tasks list in Tasks view.

4. Click Cancel to dismiss the Spelling dialog box.

The spelling check is complete, but the corrections will not be made until you 

complete the tasks in the Tasks list.

Replacing Text on Pages

The Replace command makes it easy to find and replace content on selected pages 

or all pages in the current Web site. While you can use the command to replace text 

on the current page in Page view, using it in any other Web site view lets you 

replace text in all (or selected) pages across the current Web site.

You can replace any text that can be edited directly on the page. Other text, such as 

page titles in page banners or text contained in FrontPage-based components, 

cannot be automatically replaced.

To replace text on all pages in the current Web site

1. On the Edit menu, click Replace.

FrontPage displays the Replace dialog box. Here, you enter the string of text 

to be found and what you want to replace it with. You can choose to replace 

text on all pages in the current Web site, or on selected pages only.

2. Click All Pages.

3. In the Replace dialog box, type Welcome to Championzone in the Find 

what box.

4. In the Replace with box, type Thanks for visiting Championzone.

5. Click the Match case check box, and then click Find in Web.

FrontPage expands the Replace dialog box to display the progress of the 

search. The search text you want to replace is found on the home page, 

Index.htm. When the operation has been completed, FrontPage displays the 

number of occurrences it has found.

6. Click Replace in the Find and Replace dialog box.

7. FrontPage opens the home page, with the phrase Welcome to Championzone 

highlighted.
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8. Click Replace.

9. When the Finished checking pages box appears, click Back to List, and then 

click Cancel.
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Completing Web Site Tasks

Tasks view displays the list of all outstanding tasks associated with the current Web 

site. Tasks are items that need your attention before you publish the Web site.

In the previous exercises, you added tasks to a list when you deferred certain 

actions. For example, when you checked the spelling of the pages in your Web site, 

you chose to add a new task for each page containing misspellings. By adding tasks 

to the list, you can complete such corrections all at once.

If you are working in a Web development environment or on an intranet, Tasks view 

makes it easy to track Web site tasks and assign them to other authors who work on 

the same Web site.

To complete tasks in Tasks view

1. On the Views bar, click the Tasks icon .

FrontPage displays the Tasks list.

2. Double-click the first task on the list, labeled Fix misspelled words.

FrontPage displays the Task Details dialog box. Here, you can see details 

about the task youve selected. You can set the priority of the task, assign it to 

another author on your network, or complete the task and remove it from the 

list.

3. In the Task Details dialog box, click Start Task.

FrontPage switches to Page view and opens the page containing the misspelled 

words.

4. In the Spelling dialog box, click Add when FrontPage questions the name 

Championzone.

This adds the word Championzone to the dictionary.

Note   FrontPage shares custom dictionaries with other Microsoft Office XP 

programs, so you don’t need to add custom words in each program separately. 

When you add verified words to your dictionary, they will not be questioned 

again.

5. Click OK.

6. FrontPage completes the spelling check. If you want, you can now return to 

Tasks view and mark this task as completed.

Although it is not required that you complete every task before publishing your 

Web site, it is a good idea to review this list when you are finished making 

changes to the Web site. Tasks view helps you manage Web sites by flagging 

important reminders for you.
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Publishing the Championzone Web site

When you publish your Web site on the World Wide  your company 

 automatically verifies your hyperlinks, the addresses of your 

pages, and the paths to your files.

Note   If you do not want to publish the Championzone Web site to your Web server, 

read this procedure for reference only, without actually completing the steps.

To publish the current Web site

1. Close all open pages in Page view.

2. On the File menu, click Publish Web, or click the Publish Web button  on 

the toolbar. 

FrontPage displays the Publish Web dialog box. Here, you specify the location 

on the World Wide Web or your corporate intranet to which you want to publish 

your Web site. Your Internet service provider can tell you this information.

You need Internet access through an Internet service provider before you can 

publish your Web site to the World Wide Web. If you want to sign on with a 

Web Presence Provider that can host FrontPage-enabled Web sites, click the 

Click here to learn more link in the Publish Destination dialog box.

3. In the Publish Web dialog box, enter the URL of your target Web server, (such 

as http://example.microsoft.com/~myweb), and then click Publish.

FrontPage publishes the current Web site from your computer to the World 

Wide Web or intranet Web server you specified.

 Tip   After you publish a Web site for the first time, you can bypass the 

Publish Web dialog box by using the Publish Web button on the 

toolbar. This quickly publishes any updates you’ve made to your pages 

without having to provide any information about the Web site’s location. 
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To again display the Publish Web dialog box, use the Publish Web 

command on the File menu instead of the toolbar button.

If FrontPage detects that you are publishing to a Web server that does not support 

the FrontPage Server Extensions, it will publish the current Web site via file transfer 

protocol (FTP).

If the Web server to which you are publishing your Web site has the FrontPage 

Server Extensions installed, your Web site will have full functionality of FrontPage-

based components and Web scripts that you may have inserted on your pages.

Publishing Web sites to a Web server that does not have the FrontPage Server 

Extensions installed may disable some functionality contained on your pages, such as 

the feedback form you added. FrontPage will display informational messages during 

the publication process to alert you of such conditions.

During the publishing process, FrontPage displays a progress bar to indicate how 

much time is required to transfer your Web site to the target Web server.

The speed at which FrontPage publishes your Web site depends on your connection 

speed, as well as the number and complexity of the pages and files in your Web site.

 Tip   When you publish a Web site, all of its pages and files are published by 

default. To exclude pages or files from being published, right-click the page or 

file in a Web site view, and click Don’t Publish.

When FrontPage has successfully published your Web site, it provides a hyperlink to 

your new Web site in the confirmation dialog box. Click the link to open the 

published Web site in your Web browser.

Finishing Lesson 2

Congratulations! You have successfully completed the FrontPage Tutorial. You are 

now ready to create and publish your very own FrontPage-based Web site.
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